Remote Network control of sooperlooperAU?

Discuss using the OSC interface to control SL

Moderator: jesse

Post Reply
Posts: 3
Joined: Sat Aug 21, 2010 5:32 pm

Remote Network control of sooperlooperAU?

Post by arvidtp »

Hi - I'm interested in running the SL GUI on a laptop separate from the laptop I am doing audio processing on, so that I can have the SL GUI always visible and always available by just reaching to another keyboard, but all the audio processing with the SL AU plugin in mainstage and other stuff like MaxMSP patches would be happening on my main laptop. My remote laptop would be a powerbook G4 (which is why its not really worth doing any audio processing on it!) with OS X 10.4.11.

When I run sooperlooper on it and attempt to connect to the IP address of my computer running mainstage and SL AU on port 10051, nothing happens - it still says "Not Connected". I am trying to do this over a LAN right now, but when performing it would be with an ethernet cable between the machines probably. I have tried variously opening, closing, connecting, disconnecting the SL AU GUI hosted in mainstage on the primary computer - nothing is working.

Is this even possible? Thanks!

PS - partial workaround would be to use ScreenRecycler (which I already own) to just use my powerbook as a 2nd monitor via VNC, but I am already pushing the CPUs to the max on my Macbook Pro. And it seems excessive :)

Edit: matter of fact, if I press connect in the prefs, not matter what it changes the IP address back to whatever is set as the default below. But it does not work, even if this default is set to the IP of the other machine - instead it seems to create a sooperlooper instance on he local machine.

Posts: 13
Joined: Tue Apr 07, 2009 3:32 pm

Re: Remote Network control of sooperlooperAU?

Post by ORL »

I experience the very same under GNU/Linux, and can't figure out how to fix it. Any help appreciated.
Posts: 117
Joined: Tue Sep 06, 2011 7:01 pm

Re: Remote Network control of sooperlooperAU?

Post by kasbah »

Under Linux you definitely not running the AU version of SooperLooper. The good news is that it should be much easier to run the "engine" and GUI on separate machines. What you do is run SooperLooper on one machine (from the command line).

Code: Select all

$ sooperlooper
Then find out the IP address of that machine. Let's say you find out it is
On the other machine start SLGUI:

Code: Select all

$ slgui -N -H
This tells SLGUI not to start SooperLooper (-N) and connect to a SooperLooper on machine

Of course this doesn't really help people running the AU version. It should work with the AU if you specify the port to be 10051.

Code: Select all

$ slgui -N -H -P 10051
Post Reply