audio quality occasionally gets horrible

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
mobeets
Posts: 2
Joined: Thu Dec 05, 2019 10:15 pm

audio quality occasionally gets horrible

Post by mobeets »

Hi all,

I am running raspbian on a raspberry pi 3b (headless), and I am running sooperlooper with jackd and a usb audio interface. I occasionally have this audio quality issue that I can't figure out: Every so often, the quality of the audio just degrades horribly, where it gets all fuzzy/crackly/noisy. This happens even when just monitoring audio. If I hit record, the noise is in the recording, which I'm guessing means it's already in the input.

What's weird though, is if I open up alsamixer, I have an option of monitoring the audio directly from the audio interface (i.e., this monitoring doesn't depend on jack or sooperlooper), and when I do that the audio sounds PERFECTLY FINE.

I can't get my head around what might be going wrong. It doesn't seem to be a cpu/memory issue, given that the audio monitored through alsamixer sounds flawless at the same time that sooperlooper's audio sounds noisy. Eventually the noise goes away, but only for a bit. Sometimes it's never even there.

Any ideas for what might be going on? Thanks in advance!

trafficjam
Posts: 5
Joined: Sat Jan 20, 2018 4:11 am

Re: audio quality occasionally gets horrible

Post by trafficjam »

I had issues like that before where audio degrades and a quick fix for me is to run
killall jackd
qjackctl
And the audio is clean again
That’s just a bandaid but maybe will help
It was probably related to my buffer settings in jack

Post Reply