v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Report anything that appears to be a bug here.

Moderator: jesse

Post Reply
ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

This is what it looks like when build on wxwidgets 3.1.5-2
command-control-sooper-looper-wxwidgets315.png
command-control-sooper-looper-wxwidgets315.png (31.72 KiB) Viewed 4419 times
Though it is fine on 3.0.5.1-2

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

I should note this is self compile of slight modification to v1.7.8 (https://github.com/essej/sooperlooper/pull/16) so I it is possible that something in that unintentionally changed the behavior.

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

I'm also noticing that there is one or a couple-or-so pixels missing of the left edge of the MIDI Event type combobox.

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

for the record I am on Arch Linux running KDE plasma desktop on wayland, if that matters.

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

my pull #16 isn't the problem...when I recompile it with wx 3.0.5.1-2 then the window appears properly laid out.

I'm noting that https://www.wxwidgets.org/news/2021/04/ ... -released/ says:
Please notice that while 3.1.5 is officially a “development” version because it is not fully compatible with the “stable” 3.0.x, the list of backwards incompatible changes is very short, so you shouldn’t have any problems updating to this version from 3.0.x in practice, and you’re encouraged to use this release, including in production.
Maybe this difference is due to one of the "backwards incompatible changes"?

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

I seemed to have fixed with https://github.com/essej/sooperlooper/c ... c9c14a6a94 (which I append as an second commit in https://github.com/essej/sooperlooper/pull/16/) by using wxDefaultSize & wxWINDOW_VARIANT_SMALL for the wxChoice boxes. Now in 3.1.5 that windows appears correctly laid out:
command-control-sooper-looper-wxwidgets315-with-my-code-fixes-defaultsize.png
command-control-sooper-looper-wxwidgets315-with-my-code-fixes-defaultsize.png (32.59 KiB) Viewed 4408 times
just like it looked in wx3.0.5.1-2.

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough when on wxwidgets 3.1.5

Post by ericfont »

also I'm noting that the prefs also look bad on v1.7.6 when installed on Debian 11 LXQt via apt:
command-and-control-v176-debian-11-lxqt.png
command-and-control-v176-debian-11-lxqt.png (49.1 KiB) Viewed 4405 times
according to https://packages.debian.org/source/bull ... widgets3.0 Debian 11 uses wxwidgets 3.0.5.1+dfsg-2

ericfont
Posts: 36
Joined: Fri Jun 25, 2021 11:08 am

Re: v1.7.8 in Preferences the Midi Command/Control combox box size is not big enough

Post by ericfont »

I guess both my Arch Linux machine which I original reported this issue with is running KDE plasma desktop, which uses Qt. And the Debian 11 LXQt desktop also uses Qt. So maybe the issue has something to do with the Qt-based desktop environment and not wxwidgets 3.1.5.


Post Reply