Page 1 of 1

SL output problems in Mainstage 3?

Posted: Sun Sep 06, 2015 8:27 pm
by cheyenne
Hi everyone!

So, I've been using mainstages's loopback plug-ins for a while, but I needed to be able to sync loops in a Master/Slave fashion, so I downloaded SooperLooper to be able to sync my loops to each other rather than syncing them to mainstage's restrictive beat clock.

I successfully got sooperlooper recognized as a third party plug-in in Mainstage and got it to open (yay!) unfortunately, I cannot get sooperlooper to output anything. I can see that it is reviewing input information, but it is completely dead output-wise.

I saw a similar post here, and the answer for that person was to change the aux channel strip in Mainstage from mono to stereo (since the SL plug-in apparently only works in stereo). I did this, and the output is still dead.

Should I be using jack to route the input/output? When I opened jack up, it didn't recognize the SL plug in or Mainstage, so I figured I didn't need it and that all my routing needs could be handled in Mainstage.

Thanks! I hope my question is coherent!

Re: SL output problems in Mainstage 3?

Posted: Sun Apr 02, 2017 1:34 am
by redbrooklyn


been using SL in MS 2 for long time, all good.
Upgraded to MS 3.
SL not working in concerts created in MS 3.
SL is working in MS concerts created in MS 2, that have been opened in MS 3.


Re: SL output problems in Mainstage 3?

Posted: Sun Apr 02, 2017 2:11 am
by redbrooklyn

for the 3 ppl who wander through here;

In MS 3 when i made a new Audio Channel, and made it Stereo - before instantiating a SL instance - it worked.

so now to re-map all this shizz... fk

- r

Re: SL output problems in Mainstage 3?

Posted: Sun Apr 02, 2017 3:28 pm
by redbrooklyn
oh snap - EASY fix for "no sound output MS 3 problem"

In MS 3 a Concert level mono Aux channel with SL running would not output sound (the SL plugin interface was showing sound was being looped, but it would not output to the channel strip).

This worked, and without having to remap controls!

1. Make the channel stereo.
2. from the very same SL plugin that is not outputting: simply re-instantiate the SL plugin as STEREO (from the dropdown menu that appears on the SL plugin).
3. bam

I was trying to use mono SL plugs for [blah blah blah...]

- R