Page 1 of 1

Softstep works with mainstage 2 but not with logic 9

Posted: Fri Jan 13, 2012 5:20 pm
by dtrmbullet
Recently got a Softstep and it rules. Though a bit of a learning curve I would highly recommend for anyone who is looking for a jackknife foots switch.

My problem. Was able to set it up in mainstage with midi patch boy binding the controller with no problem. When I go to use the same technique in logic I can teach bind controls but sooper looper does not respond to the bindings even though logic stats the cc is being received from Softstep. I tried to load up the working bindings from mainstage into the logic instance but that didn't work so started from scratch. sooper looper is getting the messages because I am able to midi learn and have the pad presses acknowledged in the binding pref., but when pressed after added nothing happens I can't even switch between tracks. I am not able to press any buttons manually either. They just turn green for a moment (this is only when pressed manually not when pressed on the Softstep) and then don't do anything ie. record, reverse. I don't seem to be getting any sound either even though the bus that it is set to is putting out sound. My levels are up in sooper looper, but will double check during my lunch break. Also tried to load up a pre recorded loop. Worked on mainstage. Loaded up in logic but was unable to get it to start playing. Anyone have any idea of what might be causing this. I am happy I can practice using it in mainstage but would love to be able to use it in logic.

I am also running a apogee gio but it is not set to control any sooper looper controls only transport options and guitar fx and an akai mpk61 midi keyboard . Could this be interfering? If so what can I do. As I have said I have had it all working in mainstage without a hitch and if I open mainstage now it will all work.

I have tried restarting the computer, sooper looper, logic...with no luck. I am running Lion

Thanks Jesse for creating such an amazing peice of software! I plan on putting it to good use and will be sure to spread the word.

Re: Softstep works with mainstage 2 but not with logic 9

Posted: Fri Jan 13, 2012 10:36 pm
by dtrmbullet
Figured it out. You can not be in 64 bit mode to run sl as an AU even if you have the bridge open. Going to try to run it with jack as a standalone in 64 bit logic when I get home as I would like to keep low latency and I have a boat load of music devices running through the computer.