sooperlooper ubuntu hardy 64bit

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

sooperlooper ubuntu hardy 64bit

Post by bldyman »

hi all! I'm trying to install sooperlooper-1.6.10. I compiled all the packages needed as showed here http://www.essej.net/sooperlooper/download.html
but when I run

Code: Select all

$ sooperlooper 
sooperlooper: error while loading shared libraries: librubberband.so.2: cannot open shared object file: No such file or directory
help please!

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: sooperlooper ubuntu hardy 64bit

Post by jesse »

If you built librubberband, make sure it is installed in a location in your system's library path. On a 64bit system it might be easiest to ensure that it was installed in /usr/lib64, although there are other solutions. I believe someone has made some debian/ubuntu packages (looks like 1.6.9 is the latest there), check out http://activecom.free.fr/linux/

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

thank you jesse. I installed 1.6.9 version from you links and it seems to have no problems

Code: Select all

bldyman@franco:~$ sooperlooper 
SooperLooper 1.6.9
Copyright 2007 Jesse Chappell
Enhanced3DNow! detected
SSE2 detected
OSC server URI (network) is: osc.udp://franco:9951/
but i can't see any GUI!!
tips?

sremington
Posts: 23
Joined: Wed Sep 17, 2008 12:07 pm

Re: sooperlooper ubuntu hardy 64bit

Post by sremington »

The "sooperlooper" binary is the engine only. There is a separate binary that is the GUI portion. Open up another shell and run the "slgui" binary to see the GUI front end. You can actually run the slgui binary on a separate box from the engine since it communicates with the engine using the OSC protocol.

You can also start just the "slgui" binary by itself and it will fire up the engine if it is not already running.

-Seth

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

Code: Select all

bldyman@franco:~$ slgui &  
[1] 6485
bldyman@franco:~$ slgui: our URL is osc.udp://franco:12959/

[1]+  Segmentation fault      slgui
slgui seems to crash

sremington
Posts: 23
Joined: Wed Sep 17, 2008 12:07 pm

Re: sooperlooper ubuntu hardy 64bit

Post by sremington »

Just for kicks don't run it with the trailing '&' and see if the error persists. There's no need to run the program in the background.

-Seth

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

thanks for your advice seth, but the error persists

Code: Select all

bldyman@franco:~$ slgui
slgui: our URL is osc.udp://franco:10876/
Segmentation fault

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: sooperlooper ubuntu hardy 64bit

Post by jesse »

I'm guessing that build is not compatible with your system. I think you were on the right track with your own building of it. If you can post all the steps you did to build it I can help see what is missing.

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

ok, thanks, steps:
I compiled wxWidgets, libsigc++ 1.2, libsndfile, libsamplerate, liblo ≥ 0.17, libxml2, rubberband with "./configure" "make" "sudo make install"
then I compiled sooperlooper-1.6.10
bldyman wrote:but when I run

Code: Select all
$ sooperlooper
sooperlooper: error while loading shared libraries: librubberband.so.2: cannot open shared object file: No such file or directory
then I installed 1.6.9 version from you link,sooperlooper ok, but slgui.. segmentation fault
---
PS when I launch application from menu:

Code: Select all

Failed to execute child process "/usr/bin/slgui" (No such file or directory)

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: sooperlooper ubuntu hardy 64bit

Post by jesse »

First, uninstall the 1.6.9 package you downloaded.

Then put the following at the end of your ~/.bash_profile file:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib:/usr/local/lib64

Then logout, and log back in. Rebuild the latest SL, install it, then try running your built version.

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

Nothing to do. I don't know what strange problem has my ubuntu, but slgui doesn't work: segmentation fault.
I made all that you said to me.
And now also jack doesn't work
"Could not connect to JACK server as client. - Overall operation failed. "

Do you think that is a problem of 64 bit? What shall i do?
Am I a disperate case?

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

ok I ripared jack
unfortunately slgui remains
slgui: our URL is osc.udp://franco:12445/
Segmentation fault

bldyman
Posts: 8
Joined: Sun Oct 12, 2008 11:52 am

Re: sooperlooper ubuntu hardy 64bit

Post by bldyman »

ok guys,
I solved the problem, by recompiling all the packages..
thanks a lot for you support! :D

ORL
Posts: 13
Joined: Tue Apr 07, 2009 3:32 pm

Re: sooperlooper ubuntu hardy 64bit

Post by ORL »

Hi,

I just wanted to tell that the package available from the webpage you gave works with Debian Squeeze AMD 64 (with 2.6.26-8-rt16 kernel, homemade), without any problem.
Thanks a lot, I was just experiencing problems compiling it (make gave bunch of errors, first was already refered here, but others didn't).

Meunier
Posts: 1
Joined: Sat Jul 15, 2017 7:35 am

Re: sooperlooper ubuntu hardy 64bit

Post by Meunier »

ORL wrote:Hi,

I just wanted to tell that the package available from the webpage you gave works with Debian Squeeze AMD 64 (with 2.6.26-8-rt16 kernel, homemade), without any problem.
Thanks a lot, I was just experiencing problems compiling it (make gave bunch of errors, first was already refered here, but others didn't).
Is that package the latest?

Post Reply