Using Sl with USB Keyboard - not every key/letter recognized

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
torhanfract
Posts: 3
Joined: Fri Sep 23, 2016 11:39 am

Using Sl with USB Keyboard - not every key/letter recognized

Post by torhanfract »

Hi all!

New here, new to comput music, new to SL. Thank you all for help first. :D

I would like then to use SL with my usb keyboard.
I don't understand actually why there are so many keys I cannot use for binding. (105 keys keyboard)
For example numbers, arrows, etc.

Do you have any idea?


Thank you a lot again! :D
Jonathan

Freasy
Posts: 60
Joined: Fri Aug 29, 2014 5:37 pm

Re: Using Sl with USB Keyboard - not every key/letter recogn

Post by Freasy »

Hi,
what keyboard do you use? SL reacts to MIDI. It might be, that the numbers and arrows don't send MIDI, but send internal commands to the keyboard itself.

torhanfract
Posts: 3
Joined: Fri Sep 23, 2016 11:39 am

Re: Using Sl with USB Keyboard - not every key/letter recogn

Post by torhanfract »

Hi!

Thank you for your answer.

I use a rly standard USB AZERTY keyboard. (Same problem on the laptop keyboard actually).

Do you know how to use all the keys?
Thanks again

Freasy
Posts: 60
Joined: Fri Aug 29, 2014 5:37 pm

Re: Using Sl with USB Keyboard - not every key/letter recogn

Post by Freasy »

Hi,
ah, I thought you meant a real keyboard (like a piano), not the keyboard of a pc. So everything I wrote about MIDI is not relevant in this case.
I tried to set the arrow keys and it worked for me (QWERTZ keyboard on Macbook). Every key should be possible to set in Preferences => Key Bindings. Maybe it doesn't work with the layout of your keyboard (normal standard is as far as I know qwerty). If you switch the layout to english, maybe it works?
Anyway jesse has to take a look on this I guess...

torhanfract
Posts: 3
Joined: Fri Sep 23, 2016 11:39 am

Re: Using Sl with USB Keyboard - not every key/letter recogn

Post by torhanfract »

Thank you for answering.

I'll try this evening to switch to QWERTY. Interesting. Maybe it'll work.

Post Reply