Build problem 1.7.0

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
robadobdob
Posts: 1
Joined: Thu Oct 03, 2013 5:35 pm

Build problem 1.7.0

Post by robadobdob »

Error :
main_panel.cpp: In member function ‘void SooperLooperGui::MainPanel::init_loopers(int)’:
main_panel.cpp:434:33: error: invalid conversion from ‘SooperLooperGui::LooperPanel*’ to ‘int’ [-fpermissive]
/usr/local/include/wx-2.8/wx/sizer.h:517:18: error: initializing argument 1 of ‘virtual bool wxSizer::Remove(int)’ [-fpermissive]
main_panel.cpp: In member function ‘void SooperLooperGui::MainPanel::misc_action(bool, wxString)’:
main_panel.cpp:1224:132: error: ‘wxSAVE’ was not declared in this scope
main_panel.cpp:1224:139: error: ‘wxCHANGE_DIR’ was not declared in this scope
main_panel.cpp:1224:152: error: ‘wxOVERWRITE_PROMPT’ was not declared in this scope
main_panel.cpp:1243:95: error: ‘wxOPEN’ was not declared in this scope
main_panel.cpp:1243:102: error: ‘wxCHANGE_DIR’ was not declared in this scope
main_panel.cpp: In member function ‘void SooperLooperGui::MainPanel::do_load_session()’:
main_panel.cpp:1355:105: error: ‘wxOPEN’ was not declared in this scope
main_panel.cpp:1355:112: error: ‘wxCHANGE_DIR’ was not declared in this scope
main_panel.cpp: In member function ‘void SooperLooperGui::MainPanel::do_save_session(bool)’:
main_panel.cpp:1366:108: error: ‘wxSAVE’ was not declared in this scope
main_panel.cpp:1366:115: error: ‘wxCHANGE_DIR’ was not declared in this scope
main_panel.cpp:1366:128: error: ‘wxOVERWRITE_PROMPT’ was not declared in this scope
make[3]: *** [main_panel.o] Error 1
make[3]: Leaving directory `/home/rob/build/sooperlooper-1.7.0/src/gui'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/rob/build/sooperlooper-1.7.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rob/build/sooperlooper-1.7.0'
make: *** [all] Error 2


Build steps ./configure --with-wxconfig-path=/usr/local/bin/wx-config && make

wx-config --libs --cflags output:
-I/usr/local/lib/wx/include/gtk2-ansi-release-static-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread
-L/usr/local/lib -pthread /usr/local/lib/libwx_gtk2_richtext-2.8.a /usr/local/lib/libwx_gtk2_aui-2.8.a /usr/local/lib/libwx_gtk2_xrc-2.8.a /usr/local/lib/libwx_gtk2_qa-2.8.a /usr/local/lib/libwx_gtk2_html-2.8.a /usr/local/lib/libwx_gtk2_adv-2.8.a /usr/local/lib/libwx_gtk2_core-2.8.a /usr/local/lib/libwx_base_xml-2.8.a /usr/local/lib/libwx_base_net-2.8.a /usr/local/lib/libwx_base-2.8.a -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lpng -ljpeg -ltiff -lexpat -lwxregex-2.8 -lz -ldl -lm

uname -a : 3.2.0-4-rt-686-pae #1 SMP PREEMPT RT Debian 3.2.46-1+deb7u1 i686 GNU/Linux

Thanks
rob

kasbah
Posts: 117
Joined: Tue Sep 06, 2011 7:01 pm

Re: Build problem 1.7.0

Post by kasbah »

Looks like your local compile of wx isn't compatible, or maybe you need to add more than just the --wx-config-path flag to compile against it properly?

Post Reply