Lost connection to SooperLooper engine.

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
Tch3tch
Posts: 8
Joined: Fri Sep 04, 2009 5:38 am

Lost connection to SooperLooper engine.

Post by Tch3tch »

Hi! I'm running SOOPERLOOPER 1.6.13 with fedora 11 and I can't run it!

When I start sooperlooper through menu shortcut , slgui appears, and the connections appear normally into jack for few second. Then I got an error saying "Lost connection to SooperLooper engine.
See the Preferences->Connections tab to start a new one".

Now when I start SL with a shell I got :

Code: Select all

slgui: our URL is osc.udp://localhost:10974/
execing: 'sooperlooper -q -U osc.udp://localhost:10974/ -p 9951 -l 1 -c 2 -t 40 -m "/home/tch/.sooperlooper/default_midi.slb"'

slgui: spawned new engine
OSC error 97: Address family not supported by protocol
sooperlooper warning: could not open for reading: /home/tch/.sooperlooper/default_midi.slb
slgui: remote looper is at osc.udp://localhost:9951/ version=1.6.13   loopcount=1  id=1252058000
  but treating the engine URL as osc.udp://:9951/
Is it serious doctor?

Many thanks!

Tch3tch
Posts: 8
Joined: Fri Sep 04, 2009 5:38 am

Re: Lost connection to SooperLooper engine.

Post by Tch3tch »

Hi again! I was suggested to run jack and sooperlooper caring that I launch em with the same user. I did it and I got a new message :

Code: Select all

slgui: our URL is osc.udp://localhost:16270/
execing: 'sooperlooper -q -U osc.udp://localhost:16270/ -p 9951 -l 1 -c 2 -t 40 -m "/home/tch/.sooperlooper/default_midi.slb"'

slgui: spawned new engine
OSC error 97: Address family not supported by protocol
sooperlooper warning: could not open for reading: /home/tch/.sooperlooper/default_midi.slb
slgui: remote looper is at osc.udp://localhost:9951/ version=1.6.13   loopcount=1  id=1252178814
  but treating the engine URL as osc.udp://:9951/

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: Lost connection to SooperLooper engine.

Post by jesse »

Hmm, I wonder if this could be some sort of IPv6 vs IPv4 mismatch. Can you post the contents of your /etc/hosts file?

Tch3tch
Posts: 8
Joined: Fri Sep 04, 2009 5:38 am

Re: Lost connection to SooperLooper engine.

Post by Tch3tch »

Code: Select all

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: Lost connection to SooperLooper engine.

Post by jesse »

Edit /etc/hosts and take the 'localhost' out of the second line starting with ::1. Or even comment the second line out (insert a # at the front). Let me know if that helps..

consumer
Posts: 4
Joined: Wed Aug 25, 2010 5:33 pm

Re: Lost connection to SooperLooper engine.

Post by consumer »

The above worked for me; any notion of why that line was written into my hosts file? The only change I've made was updates... narrows it down to, ha; twenty or thirty things, right ;)
Thank you so much,
consumer

JeffHendricks
Posts: 48
Joined: Tue May 11, 2010 11:07 am

Re: Lost connection to SooperLooper engine.

Post by JeffHendricks »

It's because the newer Linux kernels have IPv6 enabled by default. It likely did that after an update. I will keep an eye out for this when putting SL on newer Ubuntu computers.

consumer
Posts: 4
Joined: Wed Aug 25, 2010 5:33 pm

Re: Lost connection to SooperLooper engine.

Post by consumer »

Unfortunately my /etc/hosts file gets the ::1 .... localhost6. localdomain6 .... written into it every time I restart and every time I reconnect my internet connection. This is happening even after disabling IPv6 (according to the instruction at http://fedorasolved.org/network-solutions/disable-ipv6) -a brutal method of solving the problem, to be sure, but I couldn't come up with a better one.
I'm looking for a solution, and when I find it will post it here, but in the mean time if you have any suggestion I'd appreciate it very much.
Thanks!

crazman
Posts: 1
Joined: Sun Dec 12, 2010 9:45 pm

Re: Lost connection to SooperLooper engine.

Post by crazman »

I recently upgraded all of my machines to Snow Leopard. Unfortunately none of the machines work with sooperlooper any longer. I keep getting the "Lost connection to SooperLooper engine." message when loading sooperlooper as a plugin. I have edited the /etc/hosts file and have only left 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

This has not fixed the problem and I'm looking for some help!

Thanks!

scottythecat
Posts: 2
Joined: Wed Feb 19, 2014 5:13 am

Re: Lost connection to SooperLooper engine.

Post by scottythecat »

hello forum,

this is my first visit. I'm a pro musician with good mac/multimedia knowledge, but no linux expert.
I use Ubuntu 12.04 LTS on a eeepc with 2G ram. (in fact I have 3 of them ;- )
Sooperlooper suddenly stopped working, when I plugged in a new USB hub.
I restarted the computer and did extensive troubleshooting, including many jack related actions.
I always get this "lost connection"-message.

Now I suspect sth: I changed the name of the computer some days ago (using
gksudo gedit /etc/hostname

Could this be the reason? And how can it be solved?

jesse
Posts: 527
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: Lost connection to SooperLooper engine.

Post by jesse »

What version of SL are you using and how did you get it (e.g. built it yourself, or from package?)

One thing you can do is start the two parts separately in two different terminals and post the output from each here.

$ sooperlooper

(and in another)

$ slgui

Chances are your definition of localhost is somehow broken now...

scottythecat
Posts: 2
Joined: Wed Feb 19, 2014 5:13 am

Re: Lost connection to SooperLooper engine.

Post by scottythecat »

Thanks for the answer. In the meantime I remembered the inital computer name and changed it back - success!!!

I use the version 1.6.18 that is provided by Ubuntu.
I wonder why I can't install the newest version with Ubuntu 12.04 LTS.

Sooperlooper is a great programm, I appreciate it very much.

Post Reply