solo and mute behaviour

Report anything that appears to be a bug here.

Moderator: jesse

Post Reply
magnetophon
Posts: 7
Joined: Thu Jan 16, 2014 1:08 pm

solo and mute behaviour

Post by magnetophon »

Hi,

The latest git version has unhelpfull behaviour with solo an mute:

1) You can only solo one loop at a time.
It's great to be able to break down and rebuild an arrangement with the solo buttons
2) When you unsolo, everything gets unmuted.
Expected behaviour would be to remember the state of the mutes when the first solo button was pressed, and go back to that state whn the last loop is unsoloed.

I'm pretty sure version 1.6 behaved better in this respect.
I don't know what 1.7 does cause I only checked if the alternating mono/stereo bug was still there before I installed the git version.


Speaking of which: is it possible to have more thab 1 version installed, or can you run SL from the source directory, or something?


Cheers,
Bart.

kasbah
Posts: 117
Joined: Tue Sep 06, 2011 7:01 pm

Re: solo and mute behaviour

Post by kasbah »

Hmmm.. I'll check this out when I get a chance because I did mess with these states.
Speaking of which: is it possible to have more thab 1 version installed, or can you run SL from the source directory, or something?
Yeah, you can run it from the source directory when you build it. But when you start slgui it will look for sooperlooper in your $PATH. So you can either put it in your path or start the desired sooperlooper first and then slgui with -N.

Post Reply