Page 1 of 1

SL Buttons not Recognizing Keypress

Posted: Sun Nov 17, 2013 10:26 pm
by accompanist
Hi Everyone!

I've been having some difficulty with button presses not registering in SL. Often, with one loop running, I am unable to pause or mute the loop, or initiate overdubbing. I can hit pause with a mouse click or with a MIDI keypress, and the track keeps on happily humming along. Even with 'sync' checked in the loop window, sometimes I see the message "waiting for sync", but usually this message is indefinite- the command never resolves as far as I can tell (I've waited several loop cycles with no change). I've also experienced this problem with only 1 loop. I record audio into the loop, it's playing fine, and then I pause the loop, and the audio keeps playing, and then if I trigger the loop or unpause it I have the sound of the loop TWICE at two different positions.

I've also noticed that global controls are not actually being registered by all the loops- I have a record function set to global (I don't know if I want to record to all 4 loops simultaneously), but the record button only lights up in 2 or 3 of the four loops, and recording generally only occurs on the first loop. If SooperLooper can only record to one loop at a time that's probably fine, but the variability of the problem is a mystery to me.

These seem like a lot of bugs. Is there a older more stable version of SL out?

I'm using SooperLooper 1.7.0,
Sending MIDI signals using KMI's SoftStep
qjackctl is controlling the Jack server for me
All of this is running on a Macbook Pro with OS X 10.8.5, 8 GB 1600 MHz DDR3 Ram and an i7 processor.

My Session: ... ndings.slb
My MIDI Bindings: ... ndings.slb

Re: SL Buttons not Recognizing Keypress

Posted: Tue Nov 19, 2013 2:39 am
by accompanist
I thought I'd add to the same post since this problem arose with the same setup. I saved my session with Audio. I'm using the same hardware setup described in the above post. The issue I'm having here is that the Undo button is undoing all the audio- all the different layers of overdubs. The result is a track with no audio- my MIDI binding to record_or_overdub defaults to record if I undo. Then if I redo, the audio all comes back. Any ideas?

Here's the saved session with Audio for your testing pleasure: ... dio.slsess

Re: SL Buttons not Recognizing Keypress

Posted: Thu Nov 21, 2013 2:02 am
by accompanist
I'm no programmer, but I wanted to mention that I'm willing to do a lot of legwork on my end to resolve these issues. I would really love to be able to use SooperLooper professionally. The reviews laud it as one of the best loopers out there, and working with it so far, I can definitely see the potential. If anyone has any suggestions as to places to start, ways to investigate, or processes to troubleshoot, I'd really appreciate it.

I'm getting a lot of weird behavior across the board. Sometimes buttons don't register when I click them (it takes repeated presses or long presses to get the buttons to respond). I thought maybe there was some sort of compatibility issue that was arising from using Keith McMillen's SoftStep to send MIDI signals directly to SooperLooper, but as far as I can tell using the mouse to click buttons is just as buggy.

Re: SL Buttons not Recognizing Keypress

Posted: Thu Nov 21, 2013 11:22 am
by jesse
Hey, sorry for the lack of response here.

Although SL does have some known trouble areas, the things you mentioned aren't usually a part of that! I can't reproduce any of erratic basic command response issues on my system. Just for sanity's sake, go ahead and try an older release (1.6.18) to see if anything is different. I don't expect it will be, because this sounds like a more systemic problem.

One of the things that makes SL a little weird in the world of apps is that the backend engine and the GUI are separate processes that communicate with each other using OSC via local network connections. However, when you are binding midi commands, they go straight to the engine, so the fact that you have issues both with pressing buttons via mouse and with direct midi control leads to me believe it may not be a network configuration issue.

How long are the loops you are recording and overdubbing when you have the undo problem? assuming you have enough loop memory allocated, an undo should take you to the state before your last operation. The only time it should undo everything is on a long-press (undo all), or if you undo immediately after an initial record. However, if you don't have enough loop mem to hold at least 2 copies of the loop length, you could get this behavior as you would effectively have no undo space.

I'm honestly not sure how to proceed helping you resolve the erratic command behavior on basic commands.... very troubling....

Re: SL Buttons not Recognizing Keypress

Posted: Mon Dec 02, 2013 3:48 am
by accompanist
Hey Jesse-

I've done some more troubleshooting, and I've narrowed down the problem a bit!
First, the Undo issue I thought I was having was me not understanding what holding down Undo does. Thanks for the clarification (I decided to go back and read the documentation again).
So, I'm only currently using my pedal to send MIDI signals to record, overdub, mute, and trigger, but mouseclicks seem to work fine for those commands as well as replace, substitute, multiply, insert, and changing various settings (like sync source) and levels. Normal functioning, all well and good.

Buttons like record, multiply, trigger, mute, solo, etc only give erratic behavior if I've modified the stretch parameter of any loop. Once I do that, all the buttons become randomly unresponsive (aside from the stretch parameter). It doesn't seem to matter whether or not I use the GUI via a mouse click or my midi-controller (my softstep) to control the looping engine, the randomly unresponsive behavior occurs either way. This seems to narrow the problem down quite a bit.

Changing the rate a loop is played back without altering the pitch is very important to me. In my work, I often establish a musical phrase for a professor at one tempo, and then midway through an exercise receive a request to speed up or slow down what I'm playing. I would love to be able to do this with a pedal, and then continue on my merry way overdubbing, muting, etc.

2nd, I tried to reproduce the problem with 1.6.18 and I did. This is making me think that whatever's causing the issue has more to do with a) how I have Jack set up, b) how I have my aggregate device set up, or c) how I have SL set up. I've attached screenshots of my settings windows.

Aggregate device: I use my internal sound card as my clock source, and I resample my HandSonic HPD-20 (this was to avoid some buffer overrun issues I was having with it).

I'll upload my other two screenshots (my Jack settings and my Aggregate Device settings) in a second post since the attachment limit is 3.

There's also a second, very fascinating issue:
I use mute_or_trigger on global. I had two loops running. On retriggering, it SL made two copies of the loop and played them simultaneously through the same loop, just one slightly off from the other. When the offsets occurred, they output from separate speakers. Hitting trigger would trigger both 'aspects' of the sound, but depending on when I hit trigger, the sounds aligned more or less, so that they almost sounded like a simple stereo signal, but at other times they sounded totally out of phase. This issue disappears if I use mono loops. I'm fine with using mono loops for my work at the moment. Fixing this would be interesting, but my mono workaround will also suffice.

Re: SL Buttons not Recognizing Keypress

Posted: Mon Dec 02, 2013 3:49 am
by accompanist
Here are the screenshots of my Jack settings and my Aggregate Device.

Thanks so much for getting back to me so far Jesse! I'm becoming more and more confident that I can work with this.

Let me know if there are any more tests I can do or information I can gather. I will go the distance.

Best wishes.

Re: SL Buttons not Recognizing Keypress

Posted: Mon Dec 09, 2013 5:53 pm
by jesse
You discovering that it happens when Stretch is enabled is the key. Currently no record related operations on existing stretched loops is possible! The fact the weird things happen instead of nothing is the real bug. The reason for this limitation is due to the method by which the timestretching is implemented and making it possible to overdub/etc would be quite difficult using the current infrastructure. Doing *rate* changes (pitch and speed changing together) allows for use of overdub/etc, but not time stretch. Sorry!

The only way I can think of that this feature could be done in a future version of SL, would be to render a copy of the stretched loop at whatever the current setting was, then reset stretch to off and continue. Then any further time stretch changes you do would be second generation, and be even more reduced quality.

Re: SL Buttons not Recognizing Keypress

Posted: Wed Dec 11, 2013 4:03 am
by accompanist
Hey Jesse-

:shock: I think that basically solves my problem entirely. Thanks for your help with this. I think the weird behavior I was seeing was arising from me stretching a loop, and trying buttons madly with no results. Then I would be continuing to mess with stretch with my foot, and every once in awhile, as I passed by Stretch = 1.0 while mashing buttons, something would happen, and I would think- erratic button behavior! :oops:

I tried to alter the rate and pitch simultaneously to produce the same effect, and found out that they're mutually exclusive, because as you said, that would be pitch and speed changing independently. 8-)

My solution is to use a pedal to change the stretch value on all loops if an instructor wants a slight tempo change on an ongoing exercise, then create new loops, and record/overdub on those loops only to add sound to the overall mixture. I'll keep another key to reset stretch to 1.0 on all loops so I can go back to editing loops in my headphones between combinations. I'll also keep a master volume pedal as a killswitch.

Your suggestion about rendering a copy and resetting stretch was my thought as well. I would be really interested in this feature if it would be easy to implement for you. Otherwise, I feel confident that I can bring SL to my workplace and use it on demand in a professional context.

I've solved the weird lagging and ghosting issue that was coming up by sticking to mono loops for the time being. I don't think I'll really need stereo loops for what I'm doing. If you do happen to have any ideas on why that issue was arising, do let me know. That seems like the remaining mystery.

Once again, thanks for this awesome program. Absolutely worth the investment.