Page 1 of 1

Pitch and Stretch not working in 1.6.18

Posted: Wed Jan 18, 2012 5:41 pm
by polimorfos
Pitch and Stretch do not seem to be working for me in 1.6.18 or 1.6.16
1.6.14 seems OK.

Re: Pitch and Stretch not working in 1.6.18

Posted: Wed Feb 01, 2012 10:32 pm
by kasbah
Could you give more details?

- What platform are you on?
- Are you using Sooperlooper stand-alone or AU?
- What exactly happens when you try and change pitch or stretch?
- Could you post the terminal output?

Re: Pitch and Stretch not working in 1.6.18

Posted: Thu Nov 27, 2014 11:10 am
by Freasy
Since I have the same problem here, I thought I would take over this thread.
I use Mac OSX 10.10 Yosemite, before the update it worked fine under 10.9.
The SL version is 1.7.2.
I use the GUI. So no terminal output whatsoever.
If I change pitch or stretch, nothing happens. There isn't even an OSC output. It also won't react to any OSC messages I send.

Re: Pitch and Stretch not working in 1.6.18

Posted: Fri Nov 28, 2014 1:25 pm
by jesse
It isn't terminal output, it is *Console* output, which is separate utility that shows system log output (even from running GUI apps). Not sure that it will help us here, but go ahead and post any messages that appear when you start up SL.

Re: Pitch and Stretch not working in 1.6.18

Posted: Sun Nov 30, 2014 2:40 pm
by Freasy
Ah, now I know what you mean.
Here's my console output:
console.log
(2.47 KiB) Downloaded 1047 times

Re: Pitch and Stretch not working in 1.6.18

Posted: Fri Jan 23, 2015 1:23 pm
by Pekka
I can confirm that pitch and stretch doesn't work with 1.6.18 when using as AU. Seems to work with JACK but still feels buggy, gets out of sync sometimes and stretch sounds weird too. And I'm still on Snow Leopard so can't test newer version. With 1.6.14 works fine. Also rel sync works with that version as AU but not with 1.6.18 as noted before in the other thread. 1.6.18 is not stable enough for me.

1.6.14 has funny thing though, if I press record for not selected loop, it selects the loop first and start recording with second press...

Re: Pitch and Stretch not working in 1.6.18

Posted: Sun Apr 19, 2015 12:29 pm
by knifey
Posted this in the "OSX Yosemite" thread but thought I'd post here as well. I'm using SL under the same OS and SL version as Freasy and having the exact same problem - Stretch and Pitch does not work. Nothing happens, no audible effect when activated or moved. SL 1.7.2. was tested at my work on OSX 10.9.2 (I think) and Pitch and Stretch works fine.

Looking forward to hearing of any solution to this!

Re: Pitch and Stretch not working in 1.6.18

Posted: Tue Apr 21, 2015 10:28 am
by jesse
This is really one of the strangest persistent bugs... it has always worked on my systems, I've never been able to reproduce it. I don't have 10.10 installed yet, but probably will soon.