Record Button Problem

Using SL inside Apple's Logic

Moderator: jesse

Post Reply
kem
Posts: 5
Joined: Wed Jun 15, 2011 5:15 pm

Record Button Problem

Post by kem »

Can anybody help me?
I am using the midi control peddle Softstep, and Mainstage. Mac OS 10.6.8 intel. I have been using this set up successfully for awhile until I updated both the Sooplooper and the Softstep. Now the problem I'm having is this: when I step on the the peddle that is mapped to the record button on Sooperlooper the button lights and I can record, but, when I step on the peddle again to stop recording and start playback the button gets stuck and I can't get it to stop recording with the peddle. I can use the cursor but not the foot controller. This is a real mystery that I can't seem to solve. I have tried all manor of re-programing and re-mapping.
I have a performance coming up soon and I need to solve this so I would really appreciate anybody's help.
Thanks
Kem

jesse
Posts: 516
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: Record Button Problem

Post by jesse »

Aha, reading the old forum posts here: viewtopic.php?f=12&t=1062&st=0&sk=t&sd=a&start=20
and trying it out in Mainstage gave me the answer. If you switch the plugin view to Controls you will see the huge long list... about the 16th entry down you will see 'Press/Release for', turn that OFF. Then your buttons should work properly when bound to the record [cmd] (etc) parameters, as long as they are either set to type Press/Release or Note On/Off.

Let me know if that helps.

Post Reply