Page 1 of 1

Logic 9 not validating AU

Posted: Tue Nov 03, 2009 9:07 pm
by Toronto_Looper
My logic 9 is being very finicky about the SL AU. It won't validate the plugin on start up. When I run the program anyway I have success using SL inside Logic the FIRST time. Any subsequent opening of Logic and attempt to use SL fails. Odd, yes?

Re: Logic 9 not validating AU

Posted: Tue Nov 03, 2009 11:57 pm
by jesse
Not odd at all, as it was noted and fixed a few weeks ago. I still need to make an official release of the next version that includes the fix, but here is the test version which is identical to what I will release (except intel only). ... -aufix.dmg

Re: Logic 9 not validating AU

Posted: Wed Nov 04, 2009 1:03 pm
by Toronto_Looper
Ah! Sweetness! Thank-you for your hard work Jesse.

Re: Logic 9 not validating AU

Posted: Wed Nov 04, 2009 1:49 pm
by Toronto_Looper
errr... still having a validation problem with that one too.
*** - was able to get it to validate afterall :D

Perhaps I could ask a few other questions while I'm at it?
I'm trying to use SL instead of my electrix repeater - which is noisy, relatively lo-fi and I'd like to cut down on the amount of hardware I use as I travel a bunch. I use Logic to run sequenced material and as the Master for tempo. I'm getting fairly unpredictable results however from SL - as in:
1.Sometimes the record doesn't kick in until about an 8th note after I think it should... even with the quantize set to cycle and the cycle/8ths setting set to 8 - which I think should mean that the record and trigger functions should be quantized to the downbeat of every bar? It's worked like that for a bit, but for instance today when I load the same project it's different...

2. I can only sometimes get the loops to pause when I stop Logic, and to trigger again when I start it, however the loops are always way off sync when I start Logic.

3. Loop 1 is always 4 -5db louder than the other loops - I have to trim the input gain

4. In a setup with more than 2 loops, loops 1 & 2 seem to work OK, but any loops after that end up repeating late - almost an 8th note later than what I play...

5. In general - the behaviour is erratic and unpredictable - is there some known conflicts or setup tweaks I should know about?

I'd really love to use this software in a professional performance setting as I use the repeater and of course, I'd be happy to put my money into a hard working software developer rather than try to keep my hardware from a now defunct company running!


Re: Logic 9 not validating AU

Posted: Thu Nov 05, 2009 3:25 am
by ghostly
3. Loop 1 is always 4 -5db louder than the other loops - I have to trim the input gain
Try unticking the "Main In" box.

Not sure about your other queries, probably something to do with the way SL works synching with the host (i.e. logic). I generally always sync to Loop 1 and everything is super tight but I guess that may not work for you depending on what you are trying to achieve. Maybe post a screenshot of your SL set-up, I know ticking and unticking some of the quantize and sync boxes does things that I just don't understand! :D

Re: Logic 9 not validating AU

Posted: Thu Nov 05, 2009 10:32 am
by Toronto_Looper
Thanks Ghostly - I'll try unchecking the Main In box and keep experimenting :)

Re: Logic 9 not validating AU

Posted: Fri Nov 06, 2009 12:00 am
by jesse
Sorry for the slow response....

When you have SL set up in Logic, can you do a save session from the SL GUI's session menu and send me the .slsess file?

Re: #1 & 2: I hate it when the word "sometimes" is in a problem description :( I don't have logic but I will try to reproduce your setup from your session

3: good suggestion from ghostly, let me know. Also are your loops mono or stereo (eg, are there 1 or 2 panners per loop in the SL gui)?

4: can you describe in more detail exactly what you're doing here? synced record again?

Re: Logic 9 not validating AU

Posted: Tue Nov 10, 2009 3:28 pm
by Toronto_Looper
Thanks for the reply Jesse.
My loops are stereo - there are two panners.
I am using Logic to play preprogrammed beats, send a click to my drummer, and send midi clock and occasionally commands to my guitarists Repeater, and my Repeater, which I'd like to exchange for SooperLooper. I have a Logic Porject file containing all of my bands set of tunes, and we generally jump around - changing the set from night to night. To facilitate improvisation in this setup, I use markers and the cycle locators to loop sections of the tune until the band is ready to move onto the next section.

As I said previously, I'm finding SL to be quite unpredictable in this setup. I'm finding now that it doesn't respond to midi commands all the time (which I am sending from an FCB1010 routed to SL from MidiPatchbay) - I often have to press record twice or three times for it to engage. It seems to engage at the right moment (sync'd to every bar) if it's in a blank Logic project - as soon as I add my beats (wavs or aiffs) and tempo changes, it's all quite unpredictable when record will or will not engage. The tempo changes happen between songs - so not during playback. Additionally, SL will not stop until the second press of the stop button in Logic - however it begins fine.

I'd be curious to know if anybody else is using Logic and SL in this way. I realize that Ableton Live is surely a better choice for this style of performance, but alas I own Logic :?

My slsess file:

Re: Logic 9 not validating AU

Posted: Tue Nov 10, 2009 5:48 pm
by Toronto_Looper
The more I experiment, I am finding that the majority of my problems occur when I have different tempos in one project. SL will play and react fairly well during the first song. If I even move the playhead to a different song/tempo while the project is stopped and SL has no loops loaded, SL begins to behave strangely. Any change in tempo of my project seems to make SL crazy. However, start/stop messages never quite work properly, but I have a feeling that's an issue on Logic's end.

Re: Logic 9 not validating AU

Posted: Tue Nov 10, 2009 11:15 pm
by jesse
That sounds like the probable issue. Do you have official timeline song start breaks in your session? Eg, does the musical timeline actually reset to 1:1:1 at your song breaks (and tempo changes?). Currently, when SL is an AU plugin it references what the current beat time is along with the current tempo to figure stuff out. There might be a few different ways to do it internally that would handle your scenario better though.

Re: Logic 9 not validating AU

Posted: Tue Nov 10, 2009 11:20 pm
by Toronto_Looper
Gotcha. No, it doesn't reset to 1:1:1 at song breaks. I have figured a way to make it work. I have to ensure that I never change tempos with loops loaded into SL (playing or not). It does not match tempo changes whatsoever. Is this something it should do? I would like it to - as I could get really interesting effects with my repeater by slowing tempos down - and I have a few songs that slow down 50% or more at the endings...

Thank-you :)

Re: Logic 9 not validating AU

Posted: Wed Nov 11, 2009 2:05 am
by jesse
I see that you have time-stretch enabled in your session. That should follow host tempo *if* it got the original estimate for loop's #beats and tempo right. But quantized sync might be compromised when auto-timestretching. It's one of those features with raw edges. If you turn off timestretch you might have better luck with the rest of the app syncing and behaving.

Re: Logic 9 not validating AU

Posted: Wed Nov 11, 2009 10:57 pm
by Toronto_Looper
Thanks again Jesse. I'm now beginning to get very good results. I have got it to work as well as I would like in one live project file. In another live project file, with the same buffer settings in Logic, I am finding that I have to adjust the latency settings in SL to get proper timing. I'm not sure I totally understand what those settings are dependant upon if they are requiring to be different within a similar setup...

Thanks for the attention - this is a fantastic app and I'm going to be pretty frickin' excited to liberate myself from my repeater!

Re: Logic 9 not validating AU

Posted: Wed Jan 27, 2010 11:40 am
by talaris
Hi Jesse,
I have tried using the 64-bit version of Logic and have discovered that the AU plugin will not validate. Seems fine under the 32-bit version. Are there plans to make a 64-bit version of SL and the AU plugin to?

Many Thanks,

Re: Logic 9 not validating AU

Posted: Mon Feb 15, 2010 9:11 pm
by andygridleymusic
Wow, I'm really excited about Sooper Looper. Thanks for creating such a great piece of software. I'd like to try it out (and hopefully after a successful run at it I'll be able ditch my current set up!).

I'm running Snow Leopard and Logic 9 (most current versions). For some reason Logic is not accepting the AU plug in. This is the specific error (what am I doing wrong?):


# # # 1 Global Scope Parameters:
ERROR: Parameter did not retain set value when Initialized
SLAU cleanup called

* * FAIL

Re: Logic 9 not validating AU

Posted: Mon Feb 15, 2010 10:43 pm
by jesse
Sorry about that, I *still* haven't updated the main release with this fix. You'll need to grab the version here: ... -aufix.dmg

Be sure you copy over the old AU .component file when you install it.

Re: Logic 9 not validating AU

Posted: Thu Feb 18, 2010 2:18 am
by andygridleymusic
Thank you! I can't wait to check it out!

Re: Logic 9 not validating AU

Posted: Fri Jan 28, 2011 7:20 am
by anylinux
Hey people I am new to this post so please help me to get more idea about this so even i can post my review here and be the part of this post.
Thanks in advance,
oscommerce development

Re: Logic 9 not validating AU

Posted: Wed Aug 26, 2015 4:51 pm
by jkr123123
Hi Guys,

My sooper looper AU plugin is also not getting validated when launching Logic 9.1.8 or Mainstage 2.1.3. The plugin scan just does nothing when it gets to the sooper looper plugin and has to be aborted. I have tried all the builds from 1.7.3 all the way down to 1.6.14 and neither the 32 or 64 bit plugins work. The Logic software is Academic so idk if that has anything to do with it. I am running a late 2011 macbook pro on OS10.8.5.

Re: Logic 9 not validating AU

Posted: Fri Aug 26, 2016 3:39 am
by domb
SooperLooper install on a MacBook Pro OS X YOSEMITE. I use Logic Pro X.
It does not work even in standalone. No connection! SooperLooper me to control the JACK server is running, but Jack does not work under YOSEMITE!
What to do?
Thank you