Search found 21 matches

by Pekka
Tue Mar 03, 2015 12:29 pm
Forum: Bug Reports
Topic: Midi bindings: CC On and Off reversed
Replies: 3
Views: 12767

Re: Midi bindings: CC On and Off reversed

Just to add this old thread: Using SL 1.7.3 and CC commands don't work like they should. I'm using KORG nanoKONTROL2 as controller and it sends CC value 127 when pressed and value 0 when released. SL reacts to these both, for example starts recording on press and stops recording on release. There se...
by Pekka
Wed Jan 28, 2015 9:40 am
Forum: Looping Techniques
Topic: Syncing loops with different starting points
Replies: 3
Views: 9716

Re: Syncing loops with different starting points

press record twice and it should work? I think there's no other way.
by Pekka
Fri Jan 23, 2015 3:50 pm
Forum: Looping Techniques
Topic: Syncing loops with different starting points
Replies: 3
Views: 9716

Re: Syncing loops with different starting points

Click "rel sync" on and it should work the way you want. But remember to push rec button again before beat 7 or you have an extra cycle.
by Pekka
Fri Jan 23, 2015 1:23 pm
Forum: Bug Reports
Topic: Pitch and Stretch not working in 1.6.18
Replies: 7
Views: 18386

Re: Pitch and Stretch not working in 1.6.18

I can confirm that pitch and stretch doesn't work with 1.6.18 when using as AU. Seems to work with JACK but still feels buggy, gets out of sync sometimes and stretch sounds weird too. And I'm still on Snow Leopard so can't test newer version. With 1.6.14 works fine. Also rel sync works with that ver...
by Pekka
Wed Jan 14, 2015 12:49 pm
Forum: Feature Requests
Topic: rec_or_overdub that goes to overdub with second press
Replies: 2
Views: 9782

rec_or_overdub that goes to overdub with second press

Would be nice! :) Tried to press two times but it misses a little piece of overdubbing from the beginning that way.
by Pekka
Sat Jan 10, 2015 3:39 pm
Forum: Feature Requests
Topic: Feature Request: trigger_solo
Replies: 5
Views: 13322

Re: Feature Request: trigger_solo

Thanks for the reply. I can live without the trigger but it would be nice to trigger current loop 'DJ style'. :-) Perhaps adding 'solo_on' would be the simplest solution IMO.
by Pekka
Fri Jan 09, 2015 11:02 am
Forum: Feature Requests
Topic: Feature Request: trigger_solo
Replies: 5
Views: 13322

Re: Feature Request: trigger_solo

Doesn't work right for me still! :( If I want to trigger currently soloed loop with PLAY button it also goes out of solo and I have a cacophony going as other loops start playing too. There doesn't seem to be solo_on command..? It would solve this.
by Pekka
Fri Jan 09, 2015 6:49 am
Forum: MIDI Setup
Topic: Select Next/Prev Loop - Note On/Off Issue
Replies: 10
Views: 21616

Re: Select Next/Prev Loop - Note On/Off Issue

Sorry, you seem to have added CC on /CC off in 1.7.0 release so it will solve my problem. But since I'm on OS X 10.6.8 I can't use it yet.
by Pekka
Thu Jan 08, 2015 3:15 am
Forum: Feature Requests
Topic: Feature Request: trigger_solo
Replies: 5
Views: 13322

Re: Feature Request: trigger_solo

Ok thanks, didn't realize to set multiple bindings. :-) I think it would be just mute override when other track is soloed. It would be nice to set the master loop to solo if needed.
by Pekka
Thu Jan 08, 2015 3:10 am
Forum: MIDI Setup
Topic: Select Next/Prev Loop - Note On/Off Issue
Replies: 10
Views: 21616

Re: Select Next/Prev Loop - Note On/Off Issue

There could be some setting that I don't know of. I'm now building up my loop setup and not sure if I will use Mainstage in the first place. It was a quick test. Perhaps I need to change midi channel settings or something. With AU Lab it worked straight away.
by Pekka
Tue Jan 06, 2015 12:20 pm
Forum: MIDI Setup
Topic: Select Next/Prev Loop - Note On/Off Issue
Replies: 10
Views: 21616

Re: Select Next/Prev Loop - Note On/Off Issue

Whoops.. Mainstage doesn't pass notes thru SL, so with Mainstage doesn't work for me...
by Pekka
Tue Jan 06, 2015 8:07 am
Forum: Feature Requests
Topic: Feature Request: trigger_solo
Replies: 5
Views: 13322

Feature Request: trigger_solo

Hello, I want to use SL in serial mode so that I have independent loops (different length) and they play one at a time. I have set up Korg Nanokontrol2's transport buttons to this purpose: REC as record_and_overdub_solo PLAY as trigger (should be trigger_solo) STOP as mute TRACK buttons change to pr...
by Pekka
Mon Jan 05, 2015 5:31 pm
Forum: MIDI Setup
Topic: Select Next/Prev Loop - Note On/Off Issue
Replies: 10
Views: 21616

Re: Select Next/Prev Loop - Note On/Off Issue

I assigned Nanokontrol to send notes and changed setting to "note on" so my problem solved. :) But still feels like a bug. Why does Next/prev loop have target/data range settings in a first place?
by Pekka
Mon Jan 05, 2015 4:58 pm
Forum: MIDI Setup
Topic: Select Next/Prev Loop - Note On/Off Issue
Replies: 10
Views: 21616

Re: Select Next/Prev Loop - Note On/Off Issue

I have somewhat similar issue with my Korg Nanokontrol2. It sends CC messages, on press value 0 and on release 127. When I press and release button I don't get the next loop but it jumps 2 loops forward. I tried to mess with the data range etc. but it didn't help. Is there a way to fix this? Thanks!
by Pekka
Sat Dec 27, 2014 4:15 pm
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

Yes Jesse! :-) Do it and I will definitely donate! (And have to upgrade to Lion or newer OS???)
by Pekka
Sat Dec 27, 2014 3:49 am
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

But SL still quite doesn't do what I want it to do! :roll: It's not logical that I have to end synced recording before the end of the cycle. For me It feels so much more natural to push the button on the exact beat I want recording to end. But that usually gives me 1 cycle too much which is frustrat...
by Pekka
Mon Dec 22, 2014 7:30 am
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

Got it to work. Workaround was to save session rel sync on when using JACK and then open session while using SL via AU. Weird but works now.
by Pekka
Sun Dec 14, 2014 3:45 pm
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

I tried with another macbook with same versions and still won't work. Any suggestions else than using JACK?
by Pekka
Fri Dec 12, 2014 3:39 am
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

It seems to be AU related problem. Rel sync works fine when using SL with JACK. Would be nice though to use SL as AU. I'll still try it with another computer if there's something messing things up in my system. I think rel sync simply doesn't turn on when it should and adding new loop "refreshes" th...
by Pekka
Wed Dec 10, 2014 12:43 pm
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Re: Rel sync doesn't work

OK, I'll install SL and AULab to another computer with same system and test if it works there. I was just wondering, could it be a preference file or something else corrupted? How can I uninstall SL completely other that trashing SooperLooper app and AU plugin? I installed a fresh copy of SL but it ...
by Pekka
Tue Dec 09, 2014 12:37 pm
Forum: Mac Specific Troubleshooting
Topic: Rel sync doesn't work
Replies: 11
Views: 21692

Rel sync doesn't work

Hi! First of all, thanks for the amazing piece of software Jesse! I have trouble getting rel sync working. SL 1.6.18, AUlab 2.2.2 and OS X 10.6.8. "Sync to" loop 1, "quantize" set to "cycle", "rel sync" on, Loop 2 sync on. I record loop 1 and let it play couple of cycles. Then hit record on loop 2 i...