Search found 9 matches

by EasyMac
Fri Nov 26, 2010 2:15 pm
Forum: OSC Interface
Topic: tap_tempo or loop_pos/loop_len?
Replies: 2
Views: 11342

Re: tap_tempo or loop_pos/loop_len?

Great. Thanks for the quick reply. I'll be sure to send the Maxpatch your way when I'm done with it. This is something I've been working on off and on for the past two years, and this is the third time I've restarted from scratch, now in MaxMSP instead of PureData. The program is meant to act as a w...
by EasyMac
Thu Nov 25, 2010 8:39 pm
Forum: OSC Interface
Topic: tap_tempo or loop_pos/loop_len?
Replies: 2
Views: 11342

tap_tempo or loop_pos/loop_len?

If I'm working on an alternate OSC-based MaxMSP controller/interface for SL, and I want to do transport-based time displays, what should I base my timing off of? (which is most accurate?) [tap_tempo] for each beat, subdivide based on [tempo] OR ROUND( [eighths_per_cycle] * [loop_pos] / [cycle_len] )...
by EasyMac
Thu Dec 24, 2009 11:25 pm
Forum: OSC Interface
Topic: tap_tempo not working?
Replies: 2
Views: 14924

tap_tempo not working?

So, I'm using PureData to communicate OSC to and from SL. Macbook. OS X Leopard. Latest version of SL (1.6.14). Running "standalone". I can send alternating 1s and 0s to the tap_tempo global ctrl as taps (tap_tempo apparently requires a change in the control value to register as a tap), and these ta...
by EasyMac
Wed Aug 12, 2009 11:39 pm
Forum: OSC Interface
Topic: Scaling of Sliders?
Replies: 2
Views: 9626

Re: Scaling of Sliders?

Perfect.
Thanks.
by EasyMac
Mon Aug 03, 2009 4:36 am
Forum: OSC Interface
Topic: Scaling of Sliders?
Replies: 2
Views: 9626

Scaling of Sliders?

So, I'm trying to control the sliders in SL with sliders in PureData. I'm sending the new values out of Pd by OSC. I'm starting with the dry slider. I tried sending them out as a linear scale between 0 and 1, but that yields nonlinear results visually in SL. Also, I understand that moving the slider...
by EasyMac
Fri Apr 03, 2009 12:04 pm
Forum: Mac Specific Troubleshooting
Topic: Latency with SL and JackOSX
Replies: 1
Views: 8333

Latency with SL and JackOSX

So, I'm running audio in from my Apogee Duet (a two-input, two output DAC) through JackOSX to different loops of SL, with even-numbered loops getting individual input from the first input of the Duet, and odd-numbered loops getting input from the second input of the Duet. I'm not using common/main i...
by EasyMac
Fri Apr 03, 2009 11:23 am
Forum: Bug Reports
Topic: Jack, SL, and a Loaded Session
Replies: 6
Views: 20551

Re: Jack, SL, and a Loaded Session

Is this the "Separate I/O Ports" setting? If so, I've had it on the whole time, I believe. I'm actually not sure what it does, but it sounded like something I wanted. Is it what enables each loop in and out to be registered with Jack? If so, wouldn't having this option not on keep Loops 1-5 from reg...
by EasyMac
Thu Apr 02, 2009 10:40 pm
Forum: MIDI Setup
Topic: Binding xfade
Replies: 1
Views: 7102

Binding xfade

When I right-click on xfade, it has the option to learn a MIDI binding, but when I try to teach it one, nothing happens in the MIDI Binding Editor, and that command is not in the list there. Is this control possible to bind?
by EasyMac
Thu Apr 02, 2009 10:38 pm
Forum: Bug Reports
Topic: Jack, SL, and a Loaded Session
Replies: 6
Views: 20551

Jack, SL, and a Loaded Session

I have a session I want to load every time I open SL with six loops, and the first loop (loop 0) doesn't register itself with JackOSX for individual I/O when I load the session. Loops 1-5 talk to Jack just fine, but to get in and out of Loop 0, I have to remove all six loops, add them again, and res...